Confusing (probably buggy) 'Except when I leave without timing a work item' behavior

I think the Except when I leave without timing a work item option may be buggy. (I originally just thought it just was confusing, now I think it is buggy).

With that checked I would expect to see nothing when I come back to my computer when I’m not timing anything, like when I come in to work in the morning. Instead I get this:

image

That second bubble shouldn’t be there, should it? I wasn’t timing anything when I left. If it really means ‘the last work item you timed’ then that is something else and is not what I understand the current text, Allocate the time to what I was timing when I left: [Work Item] to mean. (I wrote this paragraph before I thought it was buggy.) Actually, it shouldn’t show anything at all since it shouldn’t even care I was away.

Things got more interesting when I decided play around with the option…

TL;DR: Toggling that option to on from off while currently timing something makes that odd behavior appear. Toggling it off then on again while not timing anything makes things work as I’d expect: nothing comes up when I come back to my computer.

Some experimenting:
I decided to toggle it off to see what would happen, and still got the same window with the four options (after locking and unlocking my computer). I was still timing something at the time.

Then I wanted to see what the window would look like if I wasn’t timing, so I stopped my time and then checked (again, by locking) and got the following window with three options:

image

That looks right. I wouldn’t expect it to ask about continuing what I was doing if I wasn’t actually doing anything. (As an aside, I do think this window should also have the Resume Timing checkbox since there is an option to allocate time to something and you may want to continue what that was.)

Then things got interesting when I turned the option back on, before starting another time slice. The window didn’t come up, which is what I’d expect with that option.

I played around some more to confirm that and I was able to. I discovered that if I had something timing when I turned that option on then it still shows that window even if I’m not timing anything. (Which was the case the first day I started using Grindstone 4 last week, which explains why I’ve been seeing that behavior. I was timing when I started looking at the options and turned that on.)

But if I stop what I am timing and then turn the option off then on again, the window doesn’t come up.

I’m guessing there is an if statement in there somewhere with faulty logic that is preventing the settings change from happening when Grindstone is currently timing something, but performing the settings change when it isn’t timing something.

Bonus round!

To test that theory I decided to try the other way around. I started timing something and then turned the option off, and then stopped timing, expecting to not see a window when I should be, which would be the case if the setting didn’t properly get updated while timing.

Nope. I still got a window, but the wrong one. I got the four option one instead of the three option one that I should see. So still buggy, but not the way I expected. Hmm… :thinking:

And now I can’t get that window to go away at all! :sob:

My previous trick stopped working. Even changing the setting while timing anything doesn’t work now. I’ve tried changing while timing, not timing, exiting Grindstone, stopping, starting, stopping, then changing. All sorts of things. No matter what I am doing, timing or not, the option on or off, I always get that window with all four options now.

It has been a fun adventure. I was excited to at least get the window to go away, even though the bug is still technically there and ‘right’ thing would make it come back again. But now I have fiddled too much and got it permanently stuck. Phooie. :confused: Oh well, I hope at least my extra fiddling helps get some info about what is going on and how to fix it.

Edit: fixed some typos and formatting.

1 Like

I can confirm the option is buggy and it’s pretty annoying.

That trick works for me, sometimes I just need to restart Grindstone. I was happy already! But the bug comes back once I start timing something :(.

@daniel.henry Have you seen this? I wrote this a month ago now and I thought you’d at least acknowledge it like you did for other people’s bug reports on a different discussion thread. I understand there isn’t time in the day to fix everything, I am a developer too, but at least acknowledging my effort to help you pin down the source of the bug would be nice.

At this point I am rather annoyed and feeling like I wasted over an hour of my time to help you figure out what caused the bug as best as I can by testing quite a few scenarios that took a considerable amount of my time, time that I don’t owe you in any way, but I gave willingly to help improve your product that I enjoy using.

Bugs happen, I totally get it. If I got the prompt sometimes or just the first time I turn on the computer then it would be a bug that I would be more willing to ignore and live with, but no, it is literally every time. That isn’t some minor bug to me, that is a completely broken feature, bordering on a lie.

I hate to just vent like this but I am not spending any more time trying to fight this issue and I am not going to spend any more time trying to be eloquent and write out a well worded and concise post, I need to get back to my work, not deal with this bug.

My heart goes out to you, it really does, balancing all the issues during development is not easy. If this is far less of a priority than some other big thing, I get it. If this never gets fixed, I get it. But I had to at least let you know how it is affecting me and no doubt others that just haven’t spoken up yet. You were so responsive to the issues that popped up after the update a month ago I guess I got my hopes up. I’ll try to temper them better.
Godspeed.

Anything new about the issue? Very annoying bug.