Grindstone 4 Update not working and disabling application

Today Grindstone offered a new update and I agreed to install it.
The update failed with the error:
GS4Update.exe - Application Error
The application was unable to start correctly (0xc0000022).
Click OK to close the application.

Now whenever I try to start Grindstone itself, I get the same error and Grindstone doesn’t start. I uninstalled and reinstalled Grindstone 4 (using the newest download from the website), but the same error still occurs and Grindstone doesn’t start. When uninstalling I opted to keep the configuration and backups.
Also, my system has BeyondTrust privilege management installed, which limits access to admininstrator privileges - don’t know whether that may play a role.
What do I need to do to get Grindstone back working? Why does it still care about GS4Update.exe when I uninstalled and reinstalled the application?

Thank you!

Please open the windows event log viewer, then try to launch Grindstone, then refresh the windows event log log. Do you see anything in there that might be relevant?

Thank you for the response.
The event log shows that McAfee Endpoint Security prevented the GS4UPDATE to run:
[User] ran GS4UPDATE.EXE, which tried to access C:\WINDOWS\, violating the rule “Malware - Unsigned Processes in Untrusted Locations”, and was blocked. For information about how to respond to this event, see KB85494.
The same event also occurred for C:\USERS[User]\APPDATA\LOCAL\GRINDSTONE 4\

As I was able to install Grindstone 4 new, how can I stop the system from trying to run GS4UPDATE.EXE?

Here’s an idea. Try opening your temporary directory (just type %TEMP% into the file browser) and see if the Grindstone updater is in there. And if you find it in there, delete it. Does that fix it?

If figuring out exactly how to do that is too much of a bother, I think the Windows disk cleanup tool will also do it.

We’ve altered the setup program to do this for you automatically. Please see this post:

Thank you very much for the prompt reaction!
Deleting the installer in the %temp% directory already helped with the issue, and as it still wanted to update then I followed your instructions in the latest post and installed the newest version. Everything is working again now.
Thanks again!

1 Like

That worked for me as well. I had opened a helpdesk case here because I saw the malware message and thought it might be an issue with something here. But I followed your instructions and that worked for me. Thanks for getting on this as quick as you did!

1 Like